« 必履修教科「世界史(など)」を真面目に勉強した受験生こそ、救済されるべき。 | トップページ | ジョーシン06ご来場ありがとうございました »

2006年10月29日 (日)

Invalid command 'php_flag', perhaps mis-spelled

FreeBSDの php4, php5 の両方で観測されている話です。

security 対応をしようと portupgrade すると、次のようなエラーが(httpd-errorなどのファイルに)でます。

/usr/local/www/data/moodle/.htaccess: Invalid command 'php_flag', perhaps mis-spelled or defined by a module not included in the server configuration

回避方法は

# cd /usr/ports/lang/php5
# make config
(apacheのmoduleをOnにする。)
# make
# make deinstall
# make reinstall
です。portupgradeではapache用のmoduleが作られないのが原因です。moodleを利用してる場合に引っかかりますので御注意を。

|

« 必履修教科「世界史(など)」を真面目に勉強した受験生こそ、救済されるべき。 | トップページ | ジョーシン06ご来場ありがとうございました »

コメント

コメントを書く



(ウェブ上には掲載しません)


コメントは記事投稿者が公開するまで表示されません。



トラックバック

この記事のトラックバックURL:
http://app.cocolog-nifty.com/t/trackback/140645/12473076

この記事へのトラックバック一覧です: Invalid command 'php_flag', perhaps mis-spelled:

« 必履修教科「世界史(など)」を真面目に勉強した受験生こそ、救済されるべき。 | トップページ | ジョーシン06ご来場ありがとうございました »